summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 299312e0dc20..9227bcae862c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=kubeshark
pkgdesc="Kubeshark is an API Traffic Analyzer for Kubernetes."
-pkgver=50.4
+pkgver=51.0.18
pkgrel=1
arch=('x86_64' 'aarch64')
url="https://github.com/kubeshark/kubeshark"
@@ -11,12 +11,12 @@ makedepends=(
'go'
)
-source=(
- "${pkgname}-${pkgver}.tar.gz::https://github.com/kubeshark/kubeshark/archive/${pkgver}.tar.gz"
-)
+_latest() {
+ curl -s https://api.github.com/repos/kubeshark/kubeshark/releases | jq -r '.[0].tag_name'
+}
-sha256sums=(
- "334a28382a800f0d2f6c934f04b6f0e826cbe3f96a52e052f2cef877a5319e15"
+source=(
+ "${pkgname}-${pkgver}.tar.gz::https://github.com/kubeshark/kubeshark/archive/v${pkgver}.tar.gz"
)
build() {
@@ -43,7 +43,7 @@ build() {
-X 'github.com/kubeshark/kubeshark/misc.GitCommitHash=' \
-X 'github.com/kubeshark/kubeshark/misc.Branch=' \
-X 'github.com/kubeshark/kubeshark/misc.Platform=${platform}' \
- -X 'github.com/kubeshark/kubeshark/misc.Ver=${pkgver}' \
+ -X 'github.com/kubeshark/kubeshark/misc.Ver=v${pkgver}' \
-s -w" \
-o bin/kubeshark kubeshark.go
}
@@ -54,3 +54,7 @@ package() {
"${pkgdir}/usr/bin/kubeshark" completion bash | install -Dm644 /dev/stdin "${pkgdir}/usr/share/bash-completion/completions/kubeshark"
"${pkgdir}/usr/bin/kubeshark" completion zsh | install -Dm644 /dev/stdin "${pkgdir}/usr/share/zsh/site-functions/_kubeshark"
}
+
+sha256sums=(
+ 6b19df1956d41bd4a52bd219d8a380156c23a052d0569674e796e99b4ba38179
+)