summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index da18036a05fd..cc2c5a248cd5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,25 @@
pkgname=kvmd-webterm
-pkgver=0.18
+pkgver=0.19
pkgrel=1
-pkgdesc="Pi-KVM Web Terminal (GoTTY)"
+pkgdesc="Pi-KVM - Web terminal (ttyd)"
url="https://github.com/pi-kvm/kvmd-webterm"
license=(GPL)
arch=(any)
-depends=(kvmd gotty)
-makedepends=(go)
+depends=(kvmd ttyd)
install=$pkgname.install
source=(
$pkgname.install
$pkgname.service
+ https://raw.githubusercontent.com/tsl0922/ttyd/master/src/index.html
+ index.sed
terminal.svg
nginx.ctx-http.conf
nginx.ctx-server.conf
- index.html
manifest.yaml
)
-md5sums=(SKIP SKIP SKIP SKIP SKIP SKIP SKIP)
+md5sums=(SKIP SKIP SKIP SKIP SKIP SKIP SKIP SKIP)
package() {
@@ -33,4 +33,5 @@ package() {
mkdir -p "$pkgdir/usr/share/kvmd/extras/webterm"
cp nginx.*.conf index.html manifest.yaml "$pkgdir/usr/share/kvmd/extras/webterm"
+ sed -i -f index.sed "$pkgdir/usr/share/kvmd/extras/webterm/index.html"
}