summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..799cada6f8f7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Andrea Scarpino <andrea@archlinux.org>
+
+pkgname=kwallet-pam-git
+pkgver=r68.e411bd7
+pkgrel=1
+pkgdesc='Unlock KWallet using PAM'
+url='https://projects.kde.org/projects/playground/base/kwallet-pam'
+license=('LGPL')
+license=('GPL')
+arch=('i686' 'x86_64')
+depends=('kwallet' 'pam')
+conflicts=('kwallet-pam')
+provides=('kwallet-pam')
+makedepends=('git' 'cmake')
+source=('git://anongit.kde.org/kwallet-pam.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd kwallet-pam
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p build
+}
+
+build() {
+ cd build
+ cmake ../kwallet-pam \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_LIBDIR=usr/lib
+ make
+}
+
+package() {
+ cd build
+ make DESTDIR="${pkgdir}" install
+}