summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd7f72b07aab..80817328c65e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,24 @@
pkgname=kwctl-bin
pkgdesc='kwctl is the go-to CLI tool for Kubewarden users'
pkgver=1.7.0
-pkgrel=2
-arch=('x86_64')
+pkgrel=3
+arch=('aarch64' 'x86_64')
license=('Apache')
url='https://www.kubewarden.io/'
makedepends=('cosign')
provides=('kwctl')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/kubewarden/kwctl/releases/download/v${pkgver}/kwctl-linux-x86_64.zip")
-sha256sums=('fd245767a6e7b46cb51467290640fe542e42a0802b8e2e2d6b94675ff47dd431')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/kubewarden/kwctl/releases/download/v${pkgver}/kwctl-linux-${CARCH}.zip")
+sha256sums=('SKIP')
package() {
# Checking the signature
cosign verify-blob \
- --signature kwctl-linux-x86_64.sig \
- --cert kwctl-linux-x86_64.pem kwctl-linux-x86_64 \
+ --signature kwctl-linux-${CARCH}.sig \
+ --cert kwctl-linux-${CARCH}.pem kwctl-linux-${CARCH} \
--certificate-identity-regexp 'https://github.com/kubewarden/*' \
--certificate-oidc-issuer https://token.actions.githubusercontent.com
# Copy the binary
- install -Dm755 "kwctl-linux-x86_64" "${pkgdir}/usr/bin/kwctl"
+ install -Dm755 "kwctl-linux-${CARCH}" "${pkgdir}/usr/bin/kwctl"
} \ No newline at end of file