summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index af64854c0150..14a1bafdaa44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: zoe <chp321@gmail.com>
+# Contributor : enckse <enckse [at] gmail [dot] com>
pkgname=kxstitch
pkgver=2.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="The program that lets you create cross stitch patterns and charts."
arch=('i686' 'x86_64')
depends=('plasma-workspace' 'imagemagick')
@@ -9,8 +10,9 @@ makedepends=('cmake' 'automoc4' 'doxygen' 'patch' 'extra-cmake-modules' 'kdoctoo
url="https://userbase.kde.org/KXStitch"
license=('GPL')
source=("http://download.kde.org/stable/${pkgname}/${pkgver}/src/${pkgname}-${pkgver}.tar.xz"
- "${pkgname}.install")
-sha1sums=('3c0665ae6431632955aa00f416ebb8a34c7efcc3' '8e58ce0776eff7ef29394a2f7a089191a4af0b1d')
+ "${pkgname}.install"
+ "imagemagick.patch::https://github.com/KDE/kxstitch/commit/295773f44bfda1227d85edf065a8de14dc889159.diff")
+sha1sums=('3c0665ae6431632955aa00f416ebb8a34c7efcc3' '8e58ce0776eff7ef29394a2f7a089191a4af0b1d' 'e2d3c7ee0d9b62b7e0b1e4bcb327ee90f6edce3a')
install=${pkgname}.install
build() {
@@ -20,6 +22,8 @@ build() {
# Avoid bug in cmake :
#sed -i '5i\cmake_policy(SET CMP0002 OLD)' CMakeLists.txt
+ cp ../imagemagick.patch .
+ patch -p1 < imagemagick.patch
rm -rf build
mkdir build
cd build