summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..856a06c7e1a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Attenuation <ouyangjun1999@gmail.com>
+pkgname=kytan
+pkgver=0903be12
+pkgrel=1
+pkgdesc='High Performance Peer-to-Peer VPN by rust'
+arch=('x86_64')
+url='https://github.com/changlan/kytan'
+license=('MIT')
+makedepends=('rust')
+depends=()
+source=("${pkgname}::git+${url}")
+sha256sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm755 target/release/$pkgname "$pkgdir/usr/bin/$pkgname"
+} \ No newline at end of file