summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 10 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ececf9ce157e..404546e490fd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,20 @@
# Contributor: Jeremy Asuncion <jeremyasuncion808@gmail.com>
# Contributor: Simon Legner <Simon.Legner@gmail.com>
-pkgname=lab-bin
+_pkgname=lab
+pkgname=$_pkgname-bin
pkgver=0.17.2
-pkgrel=2
-pkgdesc="A hub-like tool for GitLab (pre-built binary release)"
+pkgrel=3
+pkgdesc='A hub-like tool for GitLab (pre-built binary release)'
arch=('x86_64')
-url="https://zaquestion.github.io/lab/"
+url="https://zaquestion.github.io/$_pkgname"
license=('custom:Unlicense')
depends=('git')
optdepends=('hub')
-makedepends=('go')
-conflicts=("${pkgname%-bin}-git" "${pkgname%-bin}")
+provides=("$_pkgname")
+conflicts=("$_pkgname")
source=("https://github.com/zaquestion/${pkgname%-bin}/releases/download/v$pkgver/lab_${pkgver}_linux_amd64.tar.gz")
-sha512sums=('d7d91e03f1030a740d440abaa0dc48eb54029807b921dad6b497c2641f54b295f916892a623286f39f53468a2477c327f51794b82dd55c763b62fd62b1bd0db9')
+sha256sums=('d7d91e03f1030a740d440abaa0dc48eb54029807b921dad6b497c2641f54b295f916892a623286f39f53468a2477c327f51794b82dd55c763b62fd62b1bd0db9')
build () {
./lab completion bash > completion.bash
@@ -22,8 +23,8 @@ build () {
}
package() {
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/${pkgname%-bin}"/LICENSE
- install -Dm755 lab "$pkgdir"/usr/bin/lab
+ install -Dm755 -t "$pkgdir/usr/bin/" $_pkgname
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
install -Dm644 completion.bash "$pkgdir/usr/share/bash-completion/completions/lab"
install -Dm644 completion.zsh "$pkgdir/usr/share/zsh/site-functions/_lab"
}