summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f1fe90456b8a..3a717cdb0c05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,26 @@
# Maintainer: Lex Black <autumn-wind@web.de>
pkgname=labwc
-pkgver=0.5.3
+pkgver=0.6.0
pkgrel=1
pkgdesc='stacking wayland compositor with look and feel from openbox'
url="https://github.com/labwc/labwc"
arch=('x86_64')
license=('GPL2')
-depends=('pango' 'wlroots>=0.15' 'wlroots<0.16' 'wayland' 'xorg-xwayland')
+depends=('pango' 'wayland' 'xorg-xwayland') # 'wlroots>=0.16' 'wlroots<0.17'
makedepends=('meson' 'scdoc' 'wayland-protocols')
+makedepends+=('vulkan-headers' 'xorgproto') # for latest compatible wlroots
optdepends=("bemenu: default launcher via Alt+F3")
source=(${pkgname}-${pkgver}.tar.gz::"https://github.com/labwc/labwc/archive/${pkgver}.tar.gz")
-b2sums=('c43c7b8f59b886436a6dce6c1e8383381ee6228d7207ec1caa84f49ddc8b0bcd772e22f18e05794a82b79f566ab54e7efb13be1d3d45c34ee81a44bf929a5304')
+b2sums=('f3d51f6d0e04b2aee199d692b5327339237813021a84c9fb7530a4b30ba2d4eb837c260c1ba402c9c1c6adf4990ec8116f9b9f61266261e655f6b9582c079c68')
+prepare() {
+ meson subprojects download wlroots --sourcedir="$pkgname-$pkgver"
+}
+
build() {
- arch-meson -Dman-pages=enabled "$pkgname-$pkgver" build
+ arch-meson -Dman-pages=enabled "$pkgname-$pkgver" build --force-fallback-for=wlroots
meson compile -C build
}