summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..069d336ffc28
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Max Bruckner
+pkgname=lampe
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Interactive bash-script to control your Philips Hue lights."
+arch=("any")
+url="https://github.com/poinck/lampe"
+license=('custom')
+depends=( 'curl' 'bc' 'zenity' )
+source=( "git+https://github.com/poinck/${pkgname}#tag=$pkgver"
+)
+md5sums=( SKIP )
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir" install
+ install -d -m 755 "$pkgdir/usr/share/licenses/lampe"
+ install -m 644 LICENSE "$pkgdir/usr/share/licenses/lampe/CC0"
+}