summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9bc4579a3870..82cced6e1e49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,17 @@
-# Maintainer: Jorge Pizarro-Callejas <jpizarrocallejas@gmail.com>
+# Maintainer: Jorge Pizarro-Callejas (jorgicio) <jpizarrocallejas@gmail.com>
+# Former Maintainer: sigmacool
+# Contributor: FabioLolix
pkgname=lanshare-git
_pkgname="LAN-Share"
-pkgver=continuous.r4.gaa7a3bc
+pkgver=1.2.1.r28.gaa7a3bc
pkgrel=1
pkgdesc="LAN Share is a cross platform local area network file transfer application, built using Qt GUI framework."
arch=(i686 x86_64 arm armv6h armv7h aarch64)
url="https://github.com/abdularis/LAN-Share"
-license=(GPL)
+license=(GPL3)
depends=(qt5-base)
+makedepends=(git)
source=("git+https://github.com/abdularis/$_pkgname.git")
sha256sums=('SKIP')
provides=(${pkgname%-git})
@@ -16,7 +19,7 @@ conflicts=(${pkgname%-git})
pkgver() {
cd "${srcdir}/${_pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags --exclude continuous | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {