summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28ddbb486a97..6627a3fbd7ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
pkgname=lastpass
-pkgver=4.17.1.7
+pkgver=4.18.1.2
pkgrel=1
_universalver=4.1.59
_chromever=4.17.0.4
-_amo_file=1067115
+_amo_file=1114760
_crx_id=hdokiejnpimakedhajhdlcegeplioahd
pkgdesc="The Universal LastPass installer for Firefox, Chrome, and Opera"
arch=('i686' 'x86_64')
@@ -27,7 +27,7 @@ source=("${pkgname}-${pkgver}.xpi::https://addons.mozilla.org/firefox/downloads/
"License.txt")
noextract=("${pkgname}-${pkgver}.xpi"
"lpchrome-${_chromever}.crx")
-sha256sums=('291e55d1ae6be1e26141beac6b46226db17adff77dc154c9e8f04e3b1cc589bc'
+sha256sums=('5f1b00c8ffba57c5ea05deee6466a0f3348bbd6a30453c1e8d012710ceefc14e'
'905474aceb9998ba25118c572f727336d239a146aad705207f78cacf9052ea29'
'e8eb3b585809d6644807727c5bd0a74ead96dd2c5a7e6d2ce29e0b6ea28b9e59'
'82af9e9296f92e92ca325449e0c2b2deb3c21f65afea45aeb823090cb32aad76'
@@ -52,6 +52,9 @@ prepare() {
package() {
cd "${srcdir}"
+ # universal native messaging host
+ install -Dm755 nplastpass$_64 "$pkgdir"/usr/lib/lastpass/nplastpass
+
# Firefox
if [[ -f ${pkgname}-${pkgver}/install.rdf ]]; then
_extension_id="$(sed -n '/.*<em:id>\(.*\)<\/em:id>.*/{s//\1/p;q}' ${pkgname}-${pkgver}/install.rdf)"
@@ -75,7 +78,6 @@ package() {
install -Dm644 firefox-com.lastpass.nplastpass.json "$pkgdir"/usr/lib/mozilla/native-messaging-hosts/com.lastpass.nplastpass.json
# Chrome(ium)
- install -Dm755 nplastpass$_64 "$pkgdir"/usr/lib/lastpass/nplastpass
for i in opt/chrome chromium chromium-dev; do
install -Dm644 com.lastpass.nplastpass.json "$pkgdir"/etc/$i/native-messaging-hosts/com.lastpass.nplastpass.json
install -Dm644 lastpass_policy_sources.json "$pkgdir"/etc/$i/policies/managed/lastpass.json