summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 24 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1791a7fb6f7a..c2cb575ccb83 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,44 @@
# Maintainer: Diab Neiroukh <officiallazerl0rd@gmail.com>
-pkgname=layan-cursor-theme-git
-_reponame='Layan-cursors'
+pkgname="layan-cursor-theme-git"
pkgver=0.0.0.7a37de2
-pkgrel=2
-pkgdesc='A x-cursor theme inspired by layan gtk theme and based on capitaine-cursors.'
+pkgrel=4
+pkgdesc='A x-cursor theme inspired by layan gtk theme and based on capitaine-cursors'
arch=("any")
-provides=("layan-cursor-theme")
-conflicts=("layan-cursor-theme")
-url="https://github.com/vinceliuice/${_reponame}"
+url="https://github.com/vinceliuice/Layan-cursors"
license=("GPL3")
makedepends=("git")
+provides=("layan-cursor-theme")
+conflicts=("layan-cursor-theme")
source=("git+${url}.git")
-sha256sums=('SKIP')
+b2sums=("SKIP")
-pkgver(){
- cd "${srcdir}/${_reponame}"
+pkgver()
+{
+ cd "Layan-cursors"
if [ $(git tag|wc -l) == 0 ]; then
echo "0.0.0.$(git log -1 --format='%h')"
else
- git describe --tags | sed 's/-/.r/; s/-g/./'
+ git describe --tags | sed "s/-/.r/; s/-g/./"
fi
}
-package() {
- dst="${pkgdir}/usr/share/icons"
- mkdir -p "${dst}"
- cd "${srcdir}/${_reponame}"
- if [ -z ${_cleancursordirname+x} ]; then
+package()
+{
+ if [ -z "${_cleancursordirname+x}" ]; then
_cleancursordirname=false
fi
+
+ mkdir -p "${pkgdir}/usr/share/icons"
+
+ cd "Layan-cursors"
if [ "$_cleancursordirname" = "true" ]; then
- cp -r dist/ "${dst}/Layan Unraveled"
- cp -r dist-border/ "${dst}/Layan"
- cp -r dist-white/ "${dst}/Layan Reborn"
+ cp -r "dist" "${dst}/Layan Unraveled"
+ cp -r "dist-border" "${dst}/Layan"
+ cp -r "dist-white" "${dst}/Layan Reborn"
else
- cp -r dist/ "${dst}/Layan-cursors"
- cp -r dist-border/ "${dst}/Layan-border-cursors"
- cp -r dist-white/ "${dst}/Layan-white-cursors"
+ cp -r "dist" "${dst}/Layan-cursors"
+ cp -r "dist-border" "${dst}/Layan-border-cursors"
+ cp -r "dist-white" "${dst}/Layan-white-cursors"
fi
}