summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 7 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 50902ade49f8..ea9548ae15ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Mikhail Swift <mikhail.swift@gmail.com>
pkgname=lazydocker
pkgver=0.8
-pkgrel=1
+pkgrel=2
pkgdesc='A simple terminal UI for docker and docker-compose, written in Go with the gocui library.'
arch=('1686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url='https://github.com/jesseduffield/lazydocker'
@@ -12,14 +12,12 @@ sha1sums=('286dd183eb16ace1689dddb2c44f21f657e13b74')
build() {
cd "${pkgname}-${pkgver}"
- go build \
- -gcflags=all=-trimpath=${PWD} \
- -asmflags=all=-trimpath=${PWD} \
- -ldflags=-extldflags=-zrelro \
- -ldflags=-extldflags=-znow \
- -ldflags "-s -w -X main.version=${pkgver}" \
- -o ${pkgname} \
- main.go
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -mod=readonly -modcacherw"
+ go build -o ${pkgname} main.go
}
package() {