summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 5 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index faa447b4cd3c..345fbde7e693 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Mikhail Swift <mikhail.swift@gmail.com>
pkgname=lazydocker-git
_pkgname=lazydocker
-pkgver=0.2.4.r2.gd590b2b
-pkgrel=2
+pkgver=0.5.r6.g787bff1
+pkgrel=1
pkgdesc='A simple terminal UI for docker and docker-compose, written in Go with the gocui library.'
arch=('1686' 'x86_64' 'armv7h' 'armv6h' 'aarch64')
url='https://github.com/jesseduffield/lazydocker'
license=('MIT')
options=('!strip' '!emptydirs')
-makedepends=('go' 'dep')
+makedepends=('go')
conflicts=('lazydocker')
provides=('lazydocker')
source=("${_pkgname}::git+https://github.com/jesseduffield/lazydocker.git#branch=master")
@@ -19,17 +19,8 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- mkdir -p gopath/src/github.com/jesseduffield/
- ln -rTsf ${_pkgname} gopath/src/github.com/jesseduffield/lazydocker
- export GOPATH="${srcdir}/gopath"
- cd gopath/src/github.com/jesseduffield/lazydocker
- dep ensure
-}
-
build() {
- export GOPATH="${srcdir}/gopath"
- cd gopath/src/github.com/jesseduffield/lazydocker
+ cd "${_pkgname}"
go build \
-gcflags=all=-trimpath=${PWD} \
-asmflags=all=-trimpath=${PWD} \
@@ -41,5 +32,5 @@ build() {
}
package() {
- install -Dm755 gopath/src/github.com/jesseduffield/lazydocker/${_pkgname} ${pkgdir}/usr/bin/${_pkgname}
+ install -Dm755 "${_pkgname}/${_pkgname}" ${pkgdir}/usr/bin/${_pkgname}
}