summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9feb6b2151ac..76612ecc64ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Ivan Marquesi Lerner <ivanmlerner@protonmail.com>
pkgname=lc0
-pkgver=0.29.0
+pkgver=0.30.0
pkgrel=1
pkgdesc="UCI-compliant chess engine designed to play chess via neural network, \
specifically those of the LeelaChessZero project."
@@ -10,10 +10,12 @@ arch=('x86_64')
url="https://lczero.org/"
license=('GPL3')
-depends=('ocl-icd' 'opencl-driver' 'openblas')
-makedepends=('git' 'meson' 'eigen' 'clang' 'opencl-headers' 'cblas')
+depends=('ocl-icd' 'openblas')
+makedepends=('git' 'meson' 'eigen' 'clang' 'opencl-headers')
checkdepends=('gtest')
-optdepends=("cudnn: Neural network library for use with nvidia GPUs")
+optdepends=("blas-openblas: Backend for use with CPUs"
+ "cudnn: Backend for use with nvidia GPUs"
+ "opencl-driver: Backend for use with OpenCL")
_weights="weights_hanse-69722-vf2.gz"
install=lc0.install
@@ -21,8 +23,9 @@ source=("$pkgname"
"$pkgname-$pkgver.tar.gz::https://github.com/LeelaChessZero/$pkgname/archive/v$pkgver.tar.gz"
"$_weights::https://storage.lczero.org/files/networks-contrib/hanse-69722-vf2.gz")
sha256sums=('cc9c40a508afd0aa2032a6eb309f69e8731a0a7d01f6601a653ae4e509772bd7'
- '3d3cd99bc5a82c5da2b8985ee6db4e1a2ff179e012da777319257d48c8a7c59d'
+ 'c5a11469364d06731b8da09bf9e1989ca6b39695add7d08bd96dd834dd0b5b2a'
'a519393981e68112628f739e261303987477058027f73c584c1e89302ec55b87')
+
noextract=('$_weights')
prepare() {