summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7a67031d23cd..ed02b8f8b387 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
# you should probably just stick with the aur/lcov package.
#
pkgname=lcov-git
-pkgver=r346.b9d6727
+pkgver=r406.43534e8
pkgrel=1
pkgdesc="Latest snapshot of lcov, a front-end for GCC's coverage testing tool gcov"
arch=('any')
@@ -15,11 +15,14 @@ url="http://ltp.sourceforge.net/coverage/lcov.php"
license=('GPL')
depends=(
'perl'
+ 'perl-capture-tiny'
+ 'perl-datetime'
+ 'perl-json-xs'
)
makedepends=('git')
conflicts=('lcov')
provides=('lcov')
-source=('git://github.com/linux-test-project/lcov.git')
+source=('git+https://github.com/linux-test-project/lcov.git')
md5sums=('SKIP')
pkgver() {
@@ -35,4 +38,5 @@ package() {
mkdir -p "$pkgdir/usr"
test -d "$pkgdir/usr/bin" || mv "$pkgdir/bin" "$pkgdir/usr/bin"
test -d "$pkgdir/usr/share" || mv "$pkgdir/share" "$pkgdir/usr/share"
+ test -d "$pkgdir/usr/lib" || mv "$pkgdir/lib" "$pkgdir/usr/lib"
}