summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c1b927584e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Alexander F Rødseth <xyproto@archlinux.org>
+
+pkgname=ldfpcfix
+pkgver=1.0
+pkgrel=1
+pkgdesc='Workaround for the ld \"contains output sections\" warning when compiling with fpc'
+arch=('any')
+url='https://github.com/xyproto/ldfpcfix'
+license=('MIT')
+makedepends=('go' 'git')
+source=("git+https://github.com/xyproto/ldfpcfix#tag=v$pkgver")
+sha256sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+
+ go build
+}
+
+package() {
+ install -Dm755 "$pkgname/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}
+
+# vim: ts=2 sw=2 et: