summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2546cc534d15..a17e4dbefe9e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,23 @@
pkgname=ldt
pkgver=1.3.1
-pkgrel=2
+pkgrel=3
pkgdesc='IDE for lua language. Standalone eclipse plugin.'
-arch=('x86_64')
+arch=('i686' 'x86_64')
url="https://eclipse.org/${pkgname}/"
license=('GPL')
depends=('java-runtime')
-source=("http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/${pkgname}/products/stable/${pkgver}/org.eclipse.${pkgname}.product-linux.gtk.x86_64.tar.gz" "${pkgname}.desktop")
-md5sums=('ffc8d97e364825d337362fa1263c0df9' '04ac4a4c273d96e7c2fb7e2d9c6c3987')
+source=("${pkgname}.desktop")
+md5sums=('04ac4a4c273d96e7c2fb7e2d9c6c3987')
+if test "$CARCH" == x86_64; then
+ source+=("http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/${pkgname}/products/stable/${pkgver}/org.eclipse.${pkgname}.product-linux.gtk.x86_64.tar.gz")
+ md5sums+=('ffc8d97e364825d337362fa1263c0df9')
+fi
+if test "$CARCH" == i686; then
+ source+=("http://ftp-stud.fht-esslingen.de/pub/Mirrors/eclipse/${pkgname}/products/stable/${pkgver}/org.eclipse.${pkgname}.product-linux.gtk.x86.tar.gz")
+ md5sums+=('3eb6411773fdb4d403b6c8ad6d047b74')
+fi
+
package() {
mkdir -p ${pkgdir}/opt/