summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 26 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 152505e8a175..2dab1f6ca261 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,36 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
# Contributor: samæ <samæ at marvid dot fr>
-pkgname=league-fonts
+pkgbase=league-fonts
+pkgname=(ttf-$pkgbase otf-$pkgbase)
pkgver=20171115
pkgrel=2
pkgdesc='A package depending on all the fonts from The League of Moveable Type'
arch=('any')
url='https://www.theleagueofmoveabletype.com'
-license=('custom:OFL')
-depends=('ttf-league-spartan'
- 'ttf-blackout'
- 'ttf-linden-hill'
- 'ttf-raleway'
- 'ttf-fanwood'
- 'ttf-sorts-mill-goudy'
- 'ttf-prociono'
- 'ttf-chunk'
- 'ttf-ostrich-sans'
- 'ttf-junction'
- 'ttf-league-gothic'
- 'ttf-league-mono'
- 'ttf-knewave'
- 'ttf-league-script-number-one'
- 'ttf-orbitron'
- 'ttf-goudy-bookletter-1911'
- 'ttf-sniglet')
-source=()
-sha256sums=()
+license=('OFL')
+_fonts=('league-spartan'
+ 'blackout'
+ 'linden-hill'
+ 'raleway'
+ 'fanwood'
+ 'sorts-mill-goudy'
+ 'prociono'
+ 'chunk'
+ 'ostrich-sans'
+ 'junction'
+ 'league-gothic'
+ 'league-mono'
+ 'knewave'
+ 'league-script'
+ 'orbitron'
+ 'goudy-bookletter-1911'
+ 'sniglet')
-package() {
- :
+package_ttf-league-fonts() {
+ depends=("${_fonts[@]/#/ttf-}")
+}
+
+package_otf-league-fonts() {
+ depends=("${_fonts[@]/#/otf-}")
}