summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4c2a0a5ea7bc..c91d0c035977 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Timofey Titovets <nefelim4ag@gmail.com>
pkgname=leagueoflegends-git
-pkgver=v0.10.12.r0.gc44d767
+pkgver=0.10.12.r0.gc44d767
pkgrel=1
pkgdesc="League of Legends helper script"
arch=('any')
@@ -11,12 +11,16 @@ license=('GPL3')
depends=('wine-lol' 'winetricks' 'bash' 'lib32-gnutls' 'lib32-libldap'
'lib32-openal' 'lib32-libpulse' 'wget')
conflicts=('leagueoflegends')
-source=("$pkgname"::'git+https://github.com/kyechou/leagueoflegends.git')
+source=("$pkgname"::'git+https://github.com/kyechou/leagueoflegends')
md5sums=('SKIP')
pkgver() {
cd "$srcdir/$pkgname"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ if git describe --long --tags >/dev/null 2>&1; then
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ else
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git describe --always)"
+ fi
}
package() {