summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b96b28fc89dc..6f4fc70ce373 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
# Maintainer: Timofey Titovets <nefelim4ag@gmail.com>
pkgname=leagueoflegends-git
-pkgver=0.13.r14.g243a74d
+pkgver=0.13.r24.g08f238a
pkgrel=1
pkgdesc="League Of Legends: Install/Run wrapper"
arch=('any')
url="https://github.com/Nefelim4ag/League-Of-Legends"
license=('GPL3')
-depends=('wine' 'winetricks' 'bash' 'lib32-gnutls' 'lib32-libldap' 'wget')
-optdepends=('lib32-libpulse: for audio' 'wine-staging: can work better')
+depends=('wine' 'winetricks' 'bash' 'lib32-gnutls' 'lib32-libldap'
+ 'lib32-openal' 'lib32-libpulse' 'wget')
conflicts=('leagueoflegends')
-source=("$pkgname"::'git://github.com/Nefelim4ag/League-Of-Legends.git#branch=master')
+source=("$pkgname"::'git+https://github.com/Nefelim4ag/League-Of-Legends.git#branch=master')
md5sums=('SKIP')
-install=leagueoflegends-git.install
-backup=("etc/leagueoflegends.conf")
pkgver() {
- cd "$pkgname"
+ cd "$srcdir/$pkgname"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "$srcdir/${pkgname}/"
+ cd "$srcdir/$pkgname"
make install PREFIX="$pkgdir"
}