summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 21 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c71191c65248..27212b8d683f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
-# Generated by debtap
# Maintainer: stardust95
-# Contributor: stardust95
+# Contributor: Namarrgon
pkgname=lebiniou
-pkgver=3.41
-pkgrel=2
-pkgdesc="Displays images that evolve with sound."
-arch=('i686' 'x86_64')
-url="https://biniou.net"
-license=('GPL2+')
-groups=('')
-depends=('alsa-lib>=1.0.16' 'ffmpeg>=4.0' 'fftw>=3.3.5' 'lebiniou-data>=3.27' 'glib2>=2.35.9' 'glibc' 'jack' 'jansson>=2.3' 'libmagick6>=6.9.10.2' 'libpulse>=0.99.1' 'libsndfile>=1.0.20' 'libulfius>=2.5.0' 'libxml2>=2.7.4' 'sdl2>=2.0.10' 'sdl2_ttf>=2.0.14' 'ttf-freefont' 'zlib>=1.1.4')
-options=('!strip' '!emptydirs')
-install=lebiniou.install
-source_i686=("http://ftp.fr.debian.org/debian/pool/main/l/lebiniou/lebiniou_3.41-1_i386.deb")
-source_x86_64=("http://ftp.fr.debian.org/debian/pool/main/l/lebiniou/lebiniou_3.41-1_amd64.deb")
-sha512sums_i686=('2c6f5369bf3bc97a4fd069121c5d5dfc0971d691ebff8664f563755201ac7879e42c529fc3c0c702a79a54a554564d17166b984512e993151f166c2a501c204b')
-sha512sums_x86_64=('553b0b99c63725f076eda99553407a635b0b662153c6c6a188da24aed7d9b0d24699badf06b4baf7eeef313576fa54f194651b441dc2cf040018fc41a0692206')
+pkgver=3.42.1
+pkgrel=1
+pkgdesc="A tool to create images from sound"
+arch=(x86_64)
+url="https://biniou.net/"
+license=('GPL')
+depends=(libmagick6 fftw sdl2_ttf libcaca ffmpeg lebiniou-data)
+source=("https://gitlab.com/lebiniou/lebiniou/-/archive/version-$pkgver/lebiniou-version-$pkgver.tar.gz")
+sha256sums=('8398bf56ee3973472772f06ce51bcf551c617d9c959bfda8147f09863da452f5')
-package(){
+build() {
+ cd "$pkgname-version-$pkgver"
- # Extract package data
- tar xf data.tar.xz -C "${pkgdir}"
+ autoreconf --install
+ export PKG_CONFIG_PATH="$PKG_CONFIG_PATH:/usr/lib/imagemagick6/pkgconfig"
+ ./configure --prefix=/usr
+ make
+}
- install -D -m644 "${pkgdir}/usr/share/doc/lebiniou/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+package() {
+ cd "$pkgname-version-$pkgver"
+ make DESTDIR="$pkgdir/" install
}
+