summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1ce1c37cfba..b5ba6c517763 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ _pkgbin=ledger-live-desktop
pkgname=ledger-live-git
pkgdesc="Ledger Live - Desktop (Git version)"
pkgver=2.49.2.r0.g77e1ae4acf
-pkgrel=2
+pkgrel=3
arch=('x86_64')
url='https://github.com/LedgerHQ/ledger-live'
license=('MIT')
@@ -19,8 +19,6 @@ sha512sums=('SKIP')
build() {
cd ${pkgname}
- export GIT_REVISION=${pkgver}
- export JOBS=max
eval "$(fnm env --shell bash)"
fnm use --install-if-missing
@@ -35,10 +33,11 @@ build() {
package() {
cd ${pkgname}/apps/${_pkgbin}
+
install -Dm644 "dist/__appImage-x64/${_pkgbin}.desktop" "${pkgdir}/usr/share/applications/${_pkgbin}.desktop"
install -dm755 "${pkgdir}/opt/${_pkgbin}"
- cp -r "dist/linux-unpacked" "${pkgdir}/opt/${_pkgbin}"
+ cp -r "dist/linux-unpacked/." "${pkgdir}/opt/${_pkgbin}"
install -dm755 "${pkgdir}/usr/bin"
ln -s "/opt/${_pkgbin}/${_pkgbin}" "${pkgdir}/usr/bin/${_pkgbin}"