summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 24 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9a999b3b1f03..78dda26ef370 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,38 @@
-# Maintainer: Hyacinthe Cartiaux <hyacinthe.cartiaux@free.fr>
-# Contributor: zhuqin <zhuqin83@gmail.com>
-pkgname=lensfun-git
-_gitname=lensfun
-pkgver=0.3.2.r2032.gad957f64
+# Maintainer: éclairevoyant
+# Contributor: Hyacinthe Cartiaux <hyacinthe.cartiaux at free dot fr>
+# Contributor: zhuqin <zhuqin83 at gmail dot com>
+
+_pkgname=lensfun
+pkgname="$_pkgname-git"
+pkgver=0.3.2.r2592.gec9412d2
pkgrel=1
-pkgdesc="Database of photographic lenses and a library that allows advanced access to the database"
-arch=(i686 x86_64)
+pkgdesc='Database of photographic lenses and associated library'
+arch=('i686' 'x86_64')
url="https://lensfun.github.io/"
license=('LGPL3')
depends=('glibc' 'glib2')
-makedepends=('git' 'python' 'libpng' 'cmake')
+makedepends=('cmake' 'git' 'libpng' 'python-setuptools')
optdepends=('python: for lensfun-update-data and lensfun-add-adapter')
-provides=('lensfun=0.3.0')
-conflicts=('lensfun')
-source=("lensfun::git+https://github.com/lensfun/lensfun.git")
-sha256sums=('SKIP')
+provides=("$_pkgname=0.3.2")
+conflicts=("$_pkgname")
+source=("git+https://github.com/lensfun/$_pkgname.git")
+b2sums=('SKIP')
pkgver() {
- cd $_gitname
- git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+ cd $_pkgname
+ git describe --long | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
}
build() {
- cd $_gitname
- cmake -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DCMAKE_BUILD_TYPE=Release \
- .
- make
+ cd $_pkgname
+ cmake -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DCMAKE_BUILD_TYPE=Release \
+ .
+ make
}
package() {
- cd $_gitname
- make DESTDIR="$pkgdir/" install
+ cd $_pkgname
+ make DESTDIR="$pkgdir/" install
}