summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 76a6634deb86..5369d407569f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,41 @@
# Maintainer: Fabrix Xm <fabrix.xm@gmail.com>
_pkgname=lesana
pkgname=lesana-git
-pkgver=v0.8.1.r22.gfea348c
+pkgver=v0.10.1.r0.gad2b595
pkgrel=1
pkgdesc="Manage collection inventories throught yaml files, develop version"
-arch=('x86_64' 'aarch64')
+arch=('any')
url="https://lesana.trueelena.org/"
-license=(GPL3)
-depends=('python-dateutil' 'python-jinja' 'python-ruamel-yaml' 'python-xapian' 'python-gitpython')
-makedepends=('python-setuptools')
-provides=(lesana)
+license=(AGPL-3.0-or-later)
+depends=('python' 'python-dateutil' 'python-jinja' 'python-ruamel-yaml' 'python-xapian' 'python-setuptools' 'python-hazwaz')
+optdepends=(
+ 'python-argcomplete: enable commandline tab completion'
+ 'git: git integration'
+ 'sh: git integration'
+ 'python-gitpython: git integration'
+)
+makedepends=(git python-build python-installer python-wheel python-setuptools-scm)
+provides=(lesana=${pkgver})
conflicts=(lesana)
source=("git+https://git.sr.ht/~valhalla/lesana")
md5sums=(SKIP)
pkgver() {
cd "${_pkgname}"
- git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --abbrev=7 | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd "${_pkgname}"
- sed -i.bpk "s/find_packages()/find_packages(exclude=['tests',])/" setup.py
+ git clean -dfx
}
build() {
cd "${_pkgname}"
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd "${_pkgname}"
- python setup.py install --skip-build --root="${pkgdir}" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}