summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 39 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a77c85a62943..3c6305458b99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,32 @@
-# Maintainer: Andrew Sun <adsun701 at gmail dot com>
+# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
+# Contributor: Andrew Sun <adsun701 at gmail dot com>
-_basename=egl-wayland
-pkgname="lib32-$_basename"
-pkgver=1.1.4
+pkgname=lib32-egl-wayland
+pkgver=1.1.13
pkgrel=1
-pkgdesc="EGLStream-based Wayland external platform (32-bit)"
-arch=(x86_64)
-url=https://github.com/NVIDIA/egl-wayland
-license=(MIT)
-depends=('lib32-wayland' 'eglexternalplatform' "$_basename")
-makedepends=('meson' 'git')
-options=(!emptydirs)
-_commit=0c8e822cccff8f4ed472a7b6ac26a215ad13abc4 # tags/1.1.4
-source=("git+$url#commit=$_commit")
+pkgdesc='EGLStream-based Wayland external platform (32-bits)'
+arch=('x86_64')
+url='https://github.com/NVIDIA/egl-wayland'
+license=('MIT')
+depends=(
+ 'lib32-wayland'
+ "egl-wayland=2:${pkgver}"
+)
+makedepends=(
+ 'meson'
+ 'git'
+ 'lib32-libglvnd'
+)
+provides=('libnvidia-egl-wayland.so')
+_commit=69ae9cf07bbec3b00a682918bf0dc845e989677 # tags/1.1.13
+options=('!emptydirs')
+source=("git+${url}#commit=${_commit}")
sha256sums=('SKIP')
pkgver() {
- cd $_basename
- git describe --tags | sed 's/-/+/g'
+ cd egl-wayland
+# echo $(git describe --tags | tr - +)
+ echo "$(git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g')"
}
prepare() {
@@ -29,11 +38,22 @@ build() {
export CXX="g++ -m32"
export PKG_CONFIG_PATH="/usr/lib32/pkgconfig"
- arch-meson ${_basename} build --libdir=/usr/lib32
- ninja -C build
+ arch-meson egl-wayland build \
+ --libdir=/usr/lib32
+
+ meson compile -C build
+}
+
+check() {
+ meson test -C build --print-errorlogs
}
package() {
- DESTDIR="$pkgdir" meson install -C build
- rm -rf "$pkgdir"/usr/{include,share,bin}
+ DESTDIR="${pkgdir}" meson install -C build
+
+ rm -rf "${pkgdir}/usr/include"
+ rm -rf "${pkgdir}/usr/share"
+ rm -rf "${pkgdir}/usr/bin"
+
+ install -Dm644 egl-wayland/COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
}