summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b2eaa10e2f7..e25bdfbd2222 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,14 @@
pkgname=lib32-libgexiv2
_pkgbase=gexiv2
pkgver=0.14.1
-pkgrel=1
+pkgrel=2
pkgdesc="GObject-based wrapper around the Exiv2 library (32-bit)"
url="https://wiki.gnome.org/Projects/gexiv2"
arch=('x86_64')
license=('GPL2')
depends=('lib32-exiv2' 'lib32-glib2' 'libgexiv2')
-makedepends=('gobject-introspection' 'meson' 'python-gobject' 'python2-gobject' 'vala')
+makedepends=('gobject-introspection' 'meson' 'python-gobject' 'vala'
+ 'lib32-gobject-introspection-runtime')
source=("https://gitlab.gnome.org/GNOME/${_pkgbase}/-/archive/${_pkgbase}-${pkgver}/${_pkgbase}-${_pkgbase}-${pkgver}.tar.gz"
"https://gitlab.gnome.org/GNOME/${_pkgbase}/-/commit/06adc8fb.patch"
"fix-32bit-compat.patch"
@@ -32,7 +33,7 @@ build() {
export CFLAGS="-m32"
export CXXFLAGS="-m32"
arch-meson "${_pkgbase}-${_pkgbase}-${pkgver}" "build" \
- -Dgtk_doc=true \
+ -Dgtk_doc=false \
--cross-file x86-linux-gnu
meson compile -C "build"
}