summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..427e3d6bfd4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Behnam Momeni <sbmomeni [at the] gmail [dot] com>
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
+# Contributor: Ionut Biru <ibiru@archlinux.org>
+
+pkgname=lib32-libgexiv2
+_pkgbase=gexiv2
+pkgver=0.12.0
+pkgrel=1
+pkgdesc="GObject-based wrapper around the Exiv2 library (32-bit)"
+url="https://wiki.gnome.org/Projects/gexiv2"
+arch=('x86_64')
+license=('GPL2')
+depends=('lib32-exiv2' 'lib32-glib2' 'libgexiv2')
+makedepends=('gobject-introspection' 'meson' 'python-gobject' 'python2-gobject' 'vala')
+source=("https://gitlab.gnome.org/GNOME/${_pkgbase}/-/archive/${_pkgbase}-${pkgver}/${_pkgbase}-${_pkgbase}-${pkgver}.tar.gz"
+ "x86-linux-gnu"
+ "pkgconf32")
+sha512sums=('47fce52c4f6943eb282e7b9d2660ec7eeacb15a0fcedd12e1eca2354b1809178c8b672720f83f95f0983328b5c7db00e940811dc580261ca1316e96996ce9a81'
+ 'c90a2e8d8753d4474afbaa5f1def579b4fe9580904b25125e2f942fa722a6ed54340e467d2ddf60ab9d3aeeeb93f5f740502cafe9a1f52d55da3bd78baa3b5c5'
+ 'f21dd90f4f9caf67854f68baddbfbfecda295cb53f0444a1c0bfb98246390ae5d48ba5a0892fecf8a7faa937ef88884743a8e4282ca98d54c0da80c5457ef066')
+
+build() {
+ mkdir -p "build"
+ arch-meson "${_pkgbase}-${_pkgbase}-${pkgver}" "build" --cross-file x86-linux-gnu --libdir=/usr/lib32
+ ninja -C "build"
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C "build" install
+ rm -r "$pkgdir/usr/"{share,include,lib}
+}
+