summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 87b7469497fc..0f4f04d016ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -90,7 +90,10 @@ build(){
--prefix='/usr'
fi
local _mflags=()
- local _nproc="$(nproc)"; _nproc=$((_nproc>8?8:_nproc))
+ local _nproc="$(nproc)"
+ if [ "${_nproc}" -gt 8 ]; then
+ _nproc=8
+ fi
if [ -z "${MAKEFLAGS:=}" ] || [ "${MAKEFLAGS//-j/}" = "${MAKEFLAGS}" ]; then
_mflags+=('-j' "${_nproc}")
fi