summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index eac2c6487594..235fd0bbf62f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,7 +12,7 @@
pkgname=lib32-mesa-minimal-git
pkgdesc="an open-source implementation of the OpenGL specification, git version"
-pkgver=22.2.0_devel.153476.b4957cdfcae
+pkgver=22.3.0_devel.158199.d7e6174c2bd4
pkgrel=1
arch=('x86_64')
makedepends=('python-mako' 'lib32-libxml2' 'lib32-libx11' 'xorgproto'
@@ -60,12 +60,18 @@ build () {
export CC="gcc -m32"
export CXX="g++ -m32"
export PKG_CONFIG=/usr/bin/i686-pc-linux-gnu-pkg-config
+
+# llvm 16 switchted to c++17 by default in https://github.com/llvm/llvm-project/commit/b4e9977fc18405d4a11cbaf1975bcadbf75920b8
+# use cpp_std=c++17 to force that version
+# can be removed once https://gitlab.freedesktop.org/mesa/mesa/-/merge_requests/17966 is merged to master
+
meson setup mesa _build \
--native-file llvm32.native \
-D b_ndebug=true \
-D b_lto=true \
-D buildtype=plain \
+ -D cpp_std=c++17 \
--wrap-mode=nofallback \
-D prefix=/usr \
-D sysconfdir=/etc \