summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 5 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2bd354f17095..189f63dfc19b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,29 +8,22 @@ pkgname=lib32-rtmpdump
_pkgname=rtmpdump
epoch=1
pkgver=2.4.r96.fa8646d
-pkgrel=2
+pkgrel=3
pkgdesc='Tool to download rtmp streams (lib32)'
arch=('x86_64')
url='http://rtmpdump.mplayerhq.hu/'
license=('GPL2' 'LGPL2.1')
-depends=('lib32-glibc' 'lib32-openssl' 'lib32-zlib' "${_pkgname}")
+depends=('lib32-glibc' 'lib32-gnutls' 'lib32-zlib' "${_pkgname}")
makedepends=('git')
provides=('librtmp.so')
options=('!makeflags')
_commit='fa8646d'
-source=("git://git.ffmpeg.org/rtmpdump#commit=${_commit}")
-sha256sums=('SKIP')
-
-pkgver() {
-cd rtmpdump
-_ver_name='2.4'
-_ver_commit='c28f1bab7822de97353849e7787b59e50bbb1428'
-
-echo "${_ver_name}.r$(git rev-list --count ${_ver_commit}..HEAD).${_commit}"
-}
+source=("git+https://git.ffmpeg.org/rtmpdump#commit=${_commit}")
+md5sums=('SKIP')
prepare() {
cd rtmpdump
+sed -e 's/^CRYPTO=OPENSSL/#CRYPTO=OPENSSL/' -e 's/#CRYPTO=GNUTLS/CRYPTO=GNUTLS/' -i Makefile -i librtmp/Makefile
sed -i -e 's:gcc:gcc -m32:' Makefile librtmp/Makefile
sed -i -e 's/host_cpu\=\"\${host\%\%-\*}\"/host_cpu\="i386"/' Makefile librtmp/Makefile
sed -i -e 's/march\=\"\${march\%\%-\*}\"/march\="i386"/' Makefile librtmp/Makefile