summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9515af20b9d2..858236e83d82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,21 +10,21 @@ arch=('x86_64')
url='https://www.github.com/systemd/systemd'
license=('GPL2' 'LGPL2.1')
depends=('lib32-gcc-libs' 'lib32-libcap' 'lib32-libgcrypt' 'lib32-libxcrypt'
- 'lib32-xz' 'lib32-zstd' 'systemd-libs-git')
+ 'lib32-xz' 'lib32-zstd' "systemd-libs-git=$pkgver")
makedepends=('git' 'gperf' 'intltool' 'lib32-acl' 'lib32-bzip2'
'lib32-curl' 'lib32-dbus' 'lib32-gcc-libs' 'lib32-glib2'
'lib32-gnutls' 'lib32-libelf' 'lib32-libidn2' 'lib32-pcre2'
'libxslt' 'meson' 'python-jinja')
-checkdepends=('systemd-git')
+checkdepends=("systemd-git=$pkgver")
provides=('libsystemd.so' 'libudev.so')
provides+=("lib32-systemd=$pkgver")
conflicts=('lib32-systemd')
options=('strip')
-source=('git+https://github.com/systemd/systemd')
+source=("$_pkgbasename-stable::git+https://github.com/systemd/systemd")
sha512sums=('SKIP')
pkgver() {
- cd "$_pkgbasename"
+ cd "$_pkgbasename-stable"
local _major=`grep -m1 version meson.build | cut -d\' -f2`
printf "%s.r%s.%s" "${_major}" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
@@ -132,7 +132,7 @@ build() {
-Dsysvrcnd-path=
)
- arch-meson "$_pkgbasename" build "${_meson_options[@]}"
+ arch-meson "$_pkgbasename-stable" build "${_meson_options[@]}"
meson compile -C build
}