summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 16 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0ccfca285e26..009bcb12f4a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,23 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=libbdplus-git
-pkgver=0.1.2.35.g1472680
+pkgver=0.2.0.0.g98a4ba1
pkgrel=1
pkgdesc="Open implementation of BD+ protocol. (GIT version)"
arch=('x86_64')
license=('LGPL')
url='http://www.videolan.org/developers/libbdplus.html'
-depends=('libaacs')
+depends=(
+ 'glibc' # libc.so
+ 'libaacs'
+ 'libgpg-error' # libgpg-error.so
+ 'libgcrypt' # libgcrypt.so
+)
makedepends=('git')
-provides=('libbdplus'
- 'libbdplus.so'
- )
+provides=(
+ 'libbdplus'
+ 'libbdplus.so'
+)
conflicts=('libbdplus')
source=('git+https://code.videolan.org/videolan/libbdplus.git')
sha256sums=('SKIP')
@@ -23,13 +29,15 @@ pkgver() {
prepare() {
mkdir -p build
+
+ sed 's|gpg-error-config|gpg-error|g' -i libbdplus/configure.ac
+}
+build() {
cd libbdplus
autoreconf -vfi
-}
-build() {
- cd build
+ cd ../build
../libbdplus/configure \
--prefix=/usr \
--disable-static