summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b6292fce003f..1fa5098496f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libbitcoin-consensus-git
pkgver=20170212
-pkgrel=1
+pkgrel=2
pkgdesc="Bitcoin Consensus Library"
arch=('i686' 'x86_64')
depends=('boost'
@@ -41,11 +41,17 @@ build() {
--sysconfdir=/etc \
--sharedstatedir=/usr/share/libbitcoin-consensus \
--localstatedir=/var/lib/libbitcoin-consensus \
- --with-gnu-ld \
- --without-tests
+ --with-gnu-ld
make -j$(($(nproc)/2))
}
+check() {
+ cd ${pkgname%-git}
+
+ msg2 'Testing...'
+ make -j$(($(nproc)/2)) check
+}
+
package() {
cd ${pkgname%-git}