summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b84f3c62a4a..d049302549a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,12 @@ sha512sums=('SKIP'
pkgver() {
cd libcap
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+
+ # Suggestions for improvement welcome!
+ printf '%s.r%s.%s' \
+ "$(_tag | sed 's/v//g')" \
+ "$(_revision)" \
+ "$(_commit)"
}
prepare() {