summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d5d07fc9fcbc..1377c2010baa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: yozi <es.mslj TA xunilhcra> backwards
# Contributor: Bernd Amend <bernd.amend+extension_system gmail com>
pkgname='libcatch-cpp-headers'
-pkgver=1.1build3
+pkgver=1.2.1
pkgrel=1
pkgdesc='C++-native framework for unit-tests using only a header file'
arch=(any)
@@ -9,13 +9,13 @@ url='http://catch-lib.net'
license=('custom:BSL')
source=('https://raw.github.com/philsquared/Catch/master/single_include/catch.hpp'
'LICENSE::https://raw.githubusercontent.com/philsquared/Catch/master/LICENSE_1_0.txt')
-sha256sums=('0de165d0fef3ff5dbf45feb1c6c92b8421a05c6268dc2d4f8fdf58fb615cbdfa'
+sha256sums=('0a8e3f6f2aa325cddb242bc797b8033be5e5ed75d2e1f6ed75fbc4efd87c6faa'
'c9bff75738922193e67fa726fa225535870d2aa1059f91452c411736284ad566')
pkgver() {
echo $(grep -oEm1 \
- "^*.*CATCH v([0-9])(\.[0-9]+)+ build ([0-9]+)" \
- catch.hpp | cut -d'v' -f2 | tr -d ' ')
+ '^.*Catch v[0-9]\.[0-9]+\.[0-9]+$' \
+ catch.hpp | cut -d'v' -f2)
}
package() {