summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 7 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8831592fb2dc..f8e1270f269d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=libdca-git
-pkgver=r100.g76c67bc
+pkgver=0.0.7.r2.g95c4bd8
pkgrel=1
pkgdesc="A library for decoding DTS Coherent Acoustics streams"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="https://www.videolan.org/developers/libdca.html"
license=('GPL2')
depends=('glibc')
makedepends=('git')
-provides=('libdca')
+provides=("libdca=$pkgver")
conflicts=('libdca')
options=('staticlibs')
source=("git+https://code.videolan.org/videolan/libdca.git")
@@ -19,16 +19,18 @@ sha256sums=('SKIP')
pkgver() {
cd "libdca"
- _rev=$(git rev-list --count --all)
+ _tag=$(git tag -l --sort -v:refname | grep -E '^v?[0-9\.]+$' | head -n1)
+ _rev=$(git rev-list --count $_tag..HEAD)
_hash=$(git rev-parse --short HEAD)
- printf "r%s.g%s" "$_rev" "$_hash"
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//'
}
build() {
cd "libdca"
./bootstrap
- ./configure --prefix="/usr"
+ ./configure \
+ --prefix="/usr"
make
}