summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ca22197b8d8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Dan Johansen <strit@manjaro.org>
+
+## Build order:
+## libdesq -> libdesqui -> desq-session -> desq-shell
+
+pkgname=libdesq
+pkgver=0.0.7
+pkgrel=1
+pkgdesc="The DesQ library to handle X11 protocols, system calls, classes and functions to be used across the DesQ project."
+arch=('x86_64' 'aarch64')
+url="https://gitlab.com/DesQ/${pkgname}"
+license=('GPL3')
+depends=('qt5-base')
+makedepends=('meson' 'ninja')
+source=("https://gitlab.com/DesQ/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
+md5sums=('309dcac10d71352853c7eb69db60c2b1')
+
+build() {
+ cd "${pkgname}-v${pkgver}"
+ meson .build --prefix=/usr --buildtype=release
+ ninja -C .build
+}
+
+package() {
+ cd "${pkgname}-v${pkgver}"
+ DESTDIR="${pkgdir}" ninja -C .build install
+}