summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac0876cb59a3..5b4d41646e12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
# Contributor: Yvan <madridista40@orange.fr>
pkgname=libfat-ogc-git
-pkgver=1.0.14.r0.g1e06c67
+pkgver=1.0.14.r3.gcf268b3
pkgrel=1
pkgdesc="Library for acessing FAT filesystems from Nintendo Gamecube/Wii homebrew (development version)"
arch=('any')
url="http://www.devkitpro.org/"
license=('custom')
-options=(!strip staticlibs)
depends=('devkitppc' 'libogc-git')
makedepends=('git')
-conflicts=('libfat-ogc' 'libfat-ogc-svn') # the -svn is a hack to support transition, can be removed later
+conflicts=('libfat-ogc')
provides=('libfat-ogc')
source=("git+https://github.com/devkitPro/libfat.git")
md5sums=('SKIP')
+options=(!strip staticlibs)
pkgver() {
cd libfat
@@ -24,7 +24,9 @@ pkgver() {
build() {
cd libfat
+ # set environment
source /etc/profile.d/devkitppc.sh
+
make include/libfatversion.h
make ogc-release
}