summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 20 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b84c05508157..5fb4f512d111 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,50 +1,41 @@
# Maintainer: Davide Depau <davide@depau.eu>
-# Contributor: Ivan Shapovalov <intelfx@intelfx.name>
-# Contributor: Sven Greiner <sven@sammyshp.de>
-# Contributor: vldmr <vldmr@lavabit.com>
-# Contributor: Thomas Krug <phragment@lavabit.com>
-# Contributor: Matthew Bauer <mjbauer95@gmail.com>
+_pkgname=libfprint
pkgname=libfprint-vfs0090-git
epoch=1
-pkgver=0.7.0.r87.g877aba1
-pkgrel=1
-pkgdesc="Library for fingerprint readers (includes WIP libre vfs0090 driver)"
+pkgver=1.90.1.r0.g82aed23
+pkgrel=2
+pkgdesc="Library for fingerprint readers (includes libre vfs0090 driver)"
arch=(i686 x86_64)
-url="https://github.com/nmikhailov/Validity90"
+url="https://github.com/3v1n0/libfprint"
license=(LGPL)
depends=(libusb nss pixman gnutls openssl)
-makedepends=(git)
+makedepends=(git meson gtk-doc)
optdepends=("fprintd: D-Bus daemon that manages fingerprint readers")
groups=(fprint-git)
-provides=(libfprint)
+provides=(libfprint libfprint-2.so=2-64)
conflicts=(libfprint)
replaces=(libfprint-vfs0090)
-source=("git+https://github.com/3v1n0/libfprint.git")
+source=("git+https://github.com/3v1n0/libfprint.git#branch=vfs0090")
md5sums=('SKIP')
pkgver() {
- cd libfprint
- git describe --long --tags 2>/dev/null | sed 's/^V_//;s/\([0-9]*-g\)/r\1/;s/[-_]/./g'
-}
-
-prepare() {
- cd libfprint
- git checkout vfs0090
- NOCONFIGURE=1 ./autogen.sh
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags 2>/dev/null | sed -e 's/^V_//;s/\([0-9]*-g\)/r\1/;s/[-_]/./g' -e 's/^v//g' -e 's/+vfs009.\..//g'
}
build() {
- cd libfprint
+ msg2 "================================= Note ====================================="
+ msg2 "This package is being renamed to libfprint-vfs009x-git since it now supports"
+ msg2 "both vfs0090 and vfs0097 sensors. Please switch to the new package as this"
+ msg2 "one will be deleted soon."
+ msg2 "============================================================================"
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --disable-static
- make
+ cd "$srcdir"
+ arch-meson $_pkgname build -D x11-examples=false -D doc=false
+ ninja -C build
}
-
package() {
- cd libfprint
-
- make DESTDIR="$pkgdir" install
+ cd "$srcdir"
+ DESTDIR="$pkgdir" ninja -C build install
}