summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 22 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7ea1340f65e5..ccb31f4d7b7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,30 @@
# Maintainer: Ignacy KuchciƄski (ignapk) <ignacykuchcinski@gmail.com>
-pkgname=libgweather-git
-_pkgname=libgweather
-pkgver=4.0.0.r8.g6a1f91a6
+_pkgname="libgweather"
+pkgname="$_pkgname-git"
+pkgver=4.2.0.r26.g9dd18c95
pkgrel=1
pkgdesc="Location and timezone database and weather-lookup library"
url="https://wiki.gnome.org/Projects/LibGWeather"
arch=(x86_64)
license=(LGPL)
-depends=(libsoup gtk3 geocode-glib dconf)
-makedepends=(gobject-introspection vala git gi-docgen glade meson python-gobject)
-provides=(libgweather libgweather-4)
-conflicts=(libgweather libgweather-4)
+depends=(
+ 'geocode-glib-2'
+ 'dconf'
+)
+makedepends=(
+ 'gobject-introspection'
+ 'vala'
+ 'git'
+ 'gi-docgen'
+ 'glade'
+ 'meson'
+ 'python-gobject'
+)
+provides=(
+ 'libgweather'
+ 'libgweather-4')
+conflicts=(${provides[@]})
source=("git+https://gitlab.gnome.org/GNOME/libgweather.git")
sha256sums=('SKIP')
@@ -21,11 +34,11 @@ pkgver() {
}
prepare() {
- cd $_pkgname
+ cd "$srcdir/$_pkgname"
}
build() {
- arch-meson $_pkgname build -D gtk_doc=true
+ arch-meson "$_pkgname" build -D gtk_doc=true
meson compile -C build
}