summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 24 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ccb31f4d7b7e..a891667c3920 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,38 @@
-# Maintainer: Ignacy Kuchciński (ignapk) <ignacykuchcinski@gmail.com>
+# Maintainer:
+# Contributor: Ignacy Kuchciński (ignapk) <ignacykuchcinski@gmail.com>
-_pkgname="libgweather"
+_pkgname='libgweather'
pkgname="$_pkgname-git"
-pkgver=4.2.0.r26.g9dd18c95
+pkgver=4.2.0.r27.g93127506
pkgrel=1
-pkgdesc="Location and timezone database and weather-lookup library"
-url="https://wiki.gnome.org/Projects/LibGWeather"
+pkgdesc='Location and timezone database and weather-lookup library'
+url='https://gitlab.gnome.org/GNOME/libgweather'
arch=(x86_64)
license=(LGPL)
+
depends=(
- 'geocode-glib-2'
'dconf'
+ 'geocode-glib-2'
+ 'json-glib'
+ 'libsoup3'
+ 'libxml2'
)
makedepends=(
- 'gobject-introspection'
- 'vala'
- 'git'
'gi-docgen'
- 'glade'
+ 'git'
+ 'gobject-introspection'
'meson'
'python-gobject'
+ 'vala'
)
+
provides=(
'libgweather'
- 'libgweather-4')
+ 'libgweather-4'
+)
conflicts=(${provides[@]})
-source=("git+https://gitlab.gnome.org/GNOME/libgweather.git")
+
+source=("$_pkgname"::"git+$url")
sha256sums=('SKIP')
pkgver() {
@@ -33,20 +40,19 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-prepare() {
- cd "$srcdir/$_pkgname"
-}
-
build() {
arch-meson "$_pkgname" build -D gtk_doc=true
meson compile -C build
}
check() {
- # Test fails without fr_FR.UTF-8 locale
meson test -C build --print-errorlogs || :
}
package() {
- DESTDIR="$pkgdir" meson install -C build
+ provides+=(
+ 'libgweather-4.so'
+ )
+
+ meson install -C build --destdir "$pkgdir"
}