summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 20 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3ae17c1efe38..5161ab652878 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,18 +4,20 @@
set -u
_pkgname='libgxps'
pkgname='libgxps-git'
-pkgver=0.2.2.r34.gda79d91
+pkgver=0.2.3.1.r0.gb62ce7e
pkgrel=1
pkgdesc='An XPS Documents library'
arch=('i686' 'x86_64')
-url='http://git.gnome.org/browse/libgxps/'
+url="https://git.gnome.org/browse/${_pkgname}/"
license=('GPL')
depends=('cairo' 'libarchive' 'libtiff')
makedepends=('git' 'gnome-common' 'gtk-doc' 'gobject-introspection')
-provides=('libgxps')
-conflicts=('libgxps')
-
-source=('git://git.gnome.org/libgxps')
+provides=("${_pkgname}=${pkgver%.r*}")
+conflicts=("${_pkgname}")
+_verurl="${url}"
+_versed="/browse/${_pkgname}/snapshot/${_pkgname}-\([0-9\.]\+\)\.tar\.xz"
+_veropt='l'
+source=("git://git.gnome.org/${_pkgname}")
sha256sums=('SKIP')
pkgver() {
@@ -28,7 +30,7 @@ pkgver() {
prepare() {
set -u
cd "${srcdir}/${_pkgname}"
- ./autogen.sh
+ ./autogen.sh --prefix='/usr'
./configure --prefix='/usr' --disable-test
set +u
}
@@ -45,5 +47,16 @@ package() {
cd "${srcdir}/${_pkgname}"
make DESTDIR="${pkgdir}/" install # This generates some /usr/lib errors
set +u
+ # Ensure there are no forbidden paths. Place at the end of package() and comment out as you find or need exceptions. (git-aurcheck)
+ ! test -d "${pkgdir}/bin" || { echo "Line ${LINENO} Forbidden: /bin"; false; }
+ ! test -d "${pkgdir}/sbin" || { echo "Line ${LINENO} Forbidden: /sbin"; false; }
+ ! test -d "${pkgdir}/lib" || { echo "Line ${LINENO} Forbidden: /lib"; false; }
+ ! test -d "${pkgdir}/share" || { echo "Line ${LINENO} Forbidden: /share"; false; }
+ ! test -d "${pkgdir}/usr/sbin" || { echo "Line ${LINENO} Forbidden: /usr/sbin"; false; }
+ ! test -d "${pkgdir}/usr/local" || { echo "Line ${LINENO} Forbidden: /usr/local"; false; }
+ ! grep -lr "/sbin" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /sbin"; false; }
+ ! grep -lr "/usr/tmp" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /usr/tmp"; false; }
+ ! grep -lr "/usr/local" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /usr/local"; false; }
+ ! pcre2grep -Ilr "(?<!/usr)/bin" "${pkgdir}" || { echo "Line ${LINENO} Forbidden: /bin"; false; }
}
set +u