summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f433d5eda936
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Emmanuel Gil Peyrot <emmanuel.peyrot@collabora.com>
+
+_pkgname=libiio
+pkgname="$_pkgname-git"
+pkgver=v0.6.r205.gb325202
+pkgrel=1
+pkgdesc="TODO"
+arch=('i686' 'x86_64' 'armv7h')
+url="https://wiki.analog.com/resources/tools-software/linux-software/libiio"
+license=('TODO')
+depends=()
+makedepends=('git')
+source=("$_pkgname::git+https://github.com/analogdevicesinc/libiio")
+md5sums=('SKIP')
+options=('debug' '!strip')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ mkdir -p "$srcdir/$_pkgname/build"
+}
+
+build() {
+ cd "$srcdir/$_pkgname/build"
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
+ -DCMAKE_INSTALL_SBINDIR=/usr/bin
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname/build"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sts=2 sw=2 et: