summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 17 insertions, 31 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 93339f2d0510..59bce04480c3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,23 @@
-# Maintainer: Gordian Edenhofer <gordian.edenhofer@gmail.com>
-
+# Maintainer: mark.blakeney at bullet-systems dot net
pkgname=libinput-gestures
-pkgver=r543.53bd344
-_commit=db6b6882d2d16022eba58a1a68cd701ccdd2047f
+pkgver=2.0
pkgrel=1
pkgdesc="Actions gestures on your touchpad using libinput"
-arch=('any')
-license=('GPL3')
-url="https://github.com/bulletmark/libinput-gestures"
-depends=('libinput' 'xdotool' 'python')
-install="${pkgname}.install"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/bulletmark/libinput-gestures/archive/${_commit}.tar.gz")
-md5sums=('bd02814350a1aae4e65e9168dbcf658b')
-
-#pkgver() {
-# cd "${srcdir}/${pkgname}-${_commit}"
-# ( set -o pipefail
-# git describe --long 2>/dev/null | sed 's/^slurm-//;s/\([^-]*-g\)/r\1/;s/-/./g' \
-# || printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-# )
-#}
-
-prepare() {
- cd "${srcdir}/${pkgname}-${_commit}"
-
- # Quick and dirty fix to make /etc/conf.d/libinput-gestures.conf the main/only configuration file
- sed -i 's/~\/.config/\/etc\/conf.d/g' libinput-gestures
-}
+url="https://github.com/bulletmark/$pkgname"
+license=("GPL3")
+arch=("any")
+depends=("python" "libinput" "xdotool")
+makedepends=("git")
+conflicts=("$pkgname-git")
+replaces=("$pkgname-git")
+backup=("etc/$pkgname.conf")
+source=("$pkgname-$pkgver::git+$url#tag=$pkgver")
+install=install.sh
+md5sums=('SKIP')
package() {
- cd "${srcdir}/${pkgname}-${_commit}"
-
- install -D -m755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
- install -D -m644 "${pkgname}.conf" "${pkgdir}/etc/conf.d/${pkgname}.conf"
- install -D -m644 "${pkgname}.desktop" "${pkgdir}/etc/xdg/autostart/${pkgname}.desktop"
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
}
+
+# vim:set ts=2 sw=2 et: