summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1dc86324137
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Joel Teichroeb <joel@teichroeb.net>
+
+pkgname=libinput-git
+pkgver=0.17.0.r2.gbd4f129
+pkgrel=1
+pkgdesc='A library to handle input devices in Wayland compositors'
+arch=(i686 x86_64)
+url='http://freedesktop.org/wiki/Software/libinput/'
+provides=("libinput=${pkgver}")
+license=('MIT')
+depends=('mtdev' 'systemd' 'libevdev')
+makedepends=('git')
+conflicts=('libinput')
+source=(git://anongit.freedesktop.org/wayland/libinput)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd libinput
+ git describe --long | sed -r 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd libinput
+
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd libinput
+ make DESTDIR="${pkgdir}" install
+}