summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 18 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1fabf22995a6..5e8e733b1087 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
# Maintainer: Daniel Bermond <dbermond@archlinux.org>
pkgname=libjpeg-xl-git
-pkgver=r1.ff09371
+pkgver=r3.g0709f3a
pkgrel=1
pkgdesc='JPEG XL image format reference implementation (git version)'
arch=('x86_64')
url='https://jpeg.org/jpegxl/'
license=('Apache')
-depends=('gcc-libs' 'shared-mime-info')
-optdepends=('libwebp: for CLI tools'
+depends=('gcc-libs')
+optdepends=('gperftools: for CLI tools'
+ 'libwebp: for CLI tools'
'openexr: for CLI tools')
-makedepends=('git' 'cmake' 'clang' 'libwebp' 'openexr' 'gtest' 'python' 'freeglut')
+makedepends=('git' 'cmake' 'clang' 'libwebp' 'openexr' 'gtest' 'python' 'freeglut'
+ 'gperftools')
provides=('libjpeg-xl')
conflicts=('libjpeg-xl')
source=('git+https://gitlab.com/wg1/jpeg-xl.git'
@@ -18,13 +20,13 @@ source=('git+https://gitlab.com/wg1/jpeg-xl.git'
'git+https://github.com/lvandeve/lodepng.git'
'git+https://github.com/mm2/Little-CMS.git'
'git+https://github.com/google/googletest'
- 'git+https://github.com/gperftools/gperftools.git'
'git+https://github.com/google/brunsli.git'
'git+https://github.com/webmproject/sjpeg.git'
'git+https://skia.googlesource.com/skcms.git'
'010-libjpeg-xl-git-remove-werror.patch'
'020-libjpeg-xl-git-fix-headers-install-path.patch'
- '030-libjpeg-xl-git-fix-gdk-pixbuf-install-path.patch')
+ '030-libjpeg-xl-git-fix-gdk-pixbuf-install-path.patch'
+ '040-libjpeg-xl-git-disable-avx2.patch')
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -33,10 +35,10 @@ sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP'
- '1d4a4f324ba33fe80cb6d68cbe65f280086c0d5ac094c4d443f94c66a5fabf6d'
- '0cfbbe7f3968648d4413649c8bb6f340749e946913e702ce250fc10c9ed5ba12'
- '5d7df9a9cfc15183915b522bfa1360e0c9034c24c7630c0da43df35326b53c3c')
+ 'f75738bb1041e1bf9104ca6156b2269f73e4503508803de183e57110b232bbfd'
+ 'ac5e30fb0a9034a935a463a3eaaec4b369fef6cf6e270cc85cce09e1f26f67c0'
+ '5d7df9a9cfc15183915b522bfa1360e0c9034c24c7630c0da43df35326b53c3c'
+ '403600ccf265966d6a03607591daab4f4129c82a0dc467e5f6b02e4762c1e341')
prepare() {
cd jpeg-xl
@@ -45,7 +47,6 @@ prepare() {
git config --local submodule.third_party/lodepng.url "${srcdir}/lodepng"
git config --local submodule.third_party/lcms.url "${srcdir}/Little-CMS"
git config --local submodule.third_party/googletest.url "${srcdir}/googletest"
- git config --local submodule.third_party/gperftools.url "${srcdir}/gperftools"
git config --local submodule.third_party/brunsli.url "${srcdir}/brunsli"
git config --local submodule.third_party/sjpeg.url "${srcdir}/sjpeg"
git config --local submodule.third_party/skcms.url "${srcdir}/skcms"
@@ -53,18 +54,21 @@ prepare() {
patch -Np1 -i "${srcdir}/010-libjpeg-xl-git-remove-werror.patch"
patch -Np1 -i "${srcdir}/020-libjpeg-xl-git-fix-headers-install-path.patch"
patch -Np1 -i "${srcdir}/030-libjpeg-xl-git-fix-gdk-pixbuf-install-path.patch"
+ patch -Np1 -i "${srcdir}/040-libjpeg-xl-git-disable-avx2.patch"
}
pkgver() {
cd jpeg-xl
- printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf 'r%s.g%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
+ export CFLAGS+=" ${CPPFLAGS}"
+ export CXXFLAGS+=" ${CPPFLAGS}"
cmake -B build -S jpeg-xl \
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
- -DJPEGXL_ENABLE_BENCHMARK:BOOL='false' \
+ -DJPEGXL_ENABLE_BENCHMARK:BOOL='true' \
-DJPEGXL_ENABLE_FUZZERS:BOOL='false' \
-DJPEGXL_ENABLE_PLUGINS:BOOL='false' \
-DJPEGXL_ENABLE_VIEWERS:BOOL='false' \
@@ -79,5 +83,5 @@ check() {
package() {
make -C build DESTDIR="$pkgdir" install
install -D -m644 jpeg-xl/plugins/mime/image-x-jxl.xml -t "${pkgdir}/usr/share/mime/packages"
- rm "${pkgdir}/usr/bin/"{cbrunsli,butteraugli_main,decode_and_encode,epf_main,ssimulacra_main,xyb_range}
+ rm "${pkgdir}/usr/bin/"{cbrunsli,butteraugli_main,decode_and_encode,epf_main,fuzzer_corpus,ssimulacra_main,xyb_range}
}