summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5e8e733b1087..ba7b182f4a38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=libjpeg-xl-git
pkgver=r3.g0709f3a
-pkgrel=1
+pkgrel=2
pkgdesc='JPEG XL image format reference implementation (git version)'
arch=('x86_64')
url='https://jpeg.org/jpegxl/'
@@ -26,7 +26,7 @@ source=('git+https://gitlab.com/wg1/jpeg-xl.git'
'010-libjpeg-xl-git-remove-werror.patch'
'020-libjpeg-xl-git-fix-headers-install-path.patch'
'030-libjpeg-xl-git-fix-gdk-pixbuf-install-path.patch'
- '040-libjpeg-xl-git-disable-avx2.patch')
+ '040-libjpeg-xl-git-disable-avx2-avx512.patch')
sha256sums=('SKIP'
'SKIP'
'SKIP'
@@ -38,7 +38,7 @@ sha256sums=('SKIP'
'f75738bb1041e1bf9104ca6156b2269f73e4503508803de183e57110b232bbfd'
'ac5e30fb0a9034a935a463a3eaaec4b369fef6cf6e270cc85cce09e1f26f67c0'
'5d7df9a9cfc15183915b522bfa1360e0c9034c24c7630c0da43df35326b53c3c'
- '403600ccf265966d6a03607591daab4f4129c82a0dc467e5f6b02e4762c1e341')
+ '74497628c1f689ab511aceb1ffb13480a1a55552a45f794fcbe3b209b91ebd28')
prepare() {
cd jpeg-xl
@@ -54,7 +54,7 @@ prepare() {
patch -Np1 -i "${srcdir}/010-libjpeg-xl-git-remove-werror.patch"
patch -Np1 -i "${srcdir}/020-libjpeg-xl-git-fix-headers-install-path.patch"
patch -Np1 -i "${srcdir}/030-libjpeg-xl-git-fix-gdk-pixbuf-install-path.patch"
- patch -Np1 -i "${srcdir}/040-libjpeg-xl-git-disable-avx2.patch"
+ patch -Np1 -i "${srcdir}/040-libjpeg-xl-git-disable-avx2-avx512.patch"
}
pkgver() {
@@ -68,7 +68,7 @@ build() {
cmake -B build -S jpeg-xl \
-DCMAKE_BUILD_TYPE:STRING='None' \
-DCMAKE_INSTALL_PREFIX:PATH='/usr' \
- -DJPEGXL_ENABLE_BENCHMARK:BOOL='true' \
+ -DJPEGXL_ENABLE_BENCHMARK:BOOL='false' \
-DJPEGXL_ENABLE_FUZZERS:BOOL='false' \
-DJPEGXL_ENABLE_PLUGINS:BOOL='false' \
-DJPEGXL_ENABLE_VIEWERS:BOOL='false' \