summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 285a052b2549..8f6d585bf645 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,15 +3,16 @@
pkgbase=libjxl
pkgname=('libjxl' 'libjxl-doc')
pkgver=0.3.7
-pkgrel=3
+pkgrel=4
pkgdesc='JPEG XL image format reference implementation'
arch=('x86_64')
url='https://jpeg.org/jpegxl/'
#license=('BSD') # license will change on the next release
license=('Apache')
makedepends=('git' 'cmake' 'clang' 'brotli' 'gdk-pixbuf2' 'giflib' 'gimp'
- 'libjpeg-turbo' 'libpng' 'openexr' 'zlib' 'libgl' 'freeglut'
- 'gtest' 'gmock' 'python' 'asciidoc' 'doxygen' 'graphviz')
+ 'gperftools' 'libjpeg-turbo' 'libpng' 'openexr' 'zlib' 'libgl'
+ 'freeglut' 'gtest' 'gmock' 'python' 'asciidoc' 'doxygen'
+ 'graphviz')
source=("git+https://github.com/libjxl/libjxl.git#tag=v${pkgver}"
'git+https://github.com/google/brotli.git'
'git+https://github.com/lvandeve/lodepng.git'
@@ -88,6 +89,7 @@ package_libjxl() {
optdepends=('gdk-pixbuf2: for gdk-pixbuf loader'
'giflib: for CLI tools'
'gimp: for gimp plugin'
+ 'gperftools: for CLI tools and gimp plugin'
'libjpeg-turbo: for CLI tools'
'libpng: for CLI tools'
'openexr: for CLI tools')