summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 6 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 806d2cfe4c2c..bed8916e514e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,23 @@
# Maintainer: Gustavo Alvarez <sl1pkn07@gmail.com>
pkgname=libkdcraw-frameworks-git
-pkgver=5.0.0.r1055.9850efb
+pkgver=5.0.0.r1065.e1a7d02
pkgrel=1
-pkgdesc="A C++ interface used to decode RAW picture. KF5 Frameworks branch (GIT version)"
-url='https://projects.kde.org/projects/kde/kdegraphics/libs/libkdcraw'
+pkgdesc="A C++ interface used to decode RAW picture. KF5 Frameworks branch. (GIT version)"
arch=('i686' 'x86_64')
+url='https://projects.kde.org/projects/kde/kdegraphics/libs/libkdcraw'
license=('GPL' 'LGPL' 'FDL')
depends=('kconfig' 'ki18n' 'libraw' 'hicolor-icon-theme')
makedepends=('extra-cmake-modules' 'kdoctools' 'git' 'python')
conflicts=('libkdcraw')
-provides=('libkdcraw')
-source=("git://anongit.kde.org/libkdcraw#branch=frameworks")
+source=('git://anongit.kde.org/libkdcraw#branch=frameworks')
sha1sums=('SKIP')
install=libkdcraw-frameworks-git.install
pkgver() {
cd libkdcraw
- _ver="$(cat CMakeLists.txt | grep -e KDCRAW_LIB_MAJOR_VERSION -e KDCRAW_LIB_MINOR_VERSION -e KDCRAW_LIB_PATCH_VERSION | head -n3 | cut -d '"' -f2)"
- echo "$(echo ${_ver} | tr ' ' .).r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ _ver="$(cat CMakeLists.txt | grep -m3 -e KDCRAW_LIB_MAJOR_VERSION -e KDCRAW_LIB_MINOR_VERSION -e KDCRAW_LIB_PATCH_VERSION | cut -d '"' -f2 | paste -sd'.')"
+ echo "${_ver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
}
prepare() {